so today i was on my computer and then i typed the wrong domain name in the url address bar in my firefox. usually i get google search when that happens, but today i got an opendns search:

so how do you prevent opendns from being your default search engine?

well, what happened to me was that i remember a while a go i had setup the dns server ip address in my network configuation setting with the opendns ip adresses for my tcpip properties

since i had set my ip address as static, all i did was to change it back to dynamic (DHCP)