i just upgraded to firefox 3 and all of the sudden im starting to see some letters with ffdd on them. i have never see this letter before. im was sure how to fix this, so i started to play with my setting and i was able to find out how you can fix this problem that it shows ff dd. so when firefox displays a ff dd you can choose universal

so to change the setting go to : VIew > Character Encoding > Auto Detect > Universal

thats it