hi everyone, just wanted to share something or better yet a problem i had with my installation of my android sdk. when i was creating the hello world from the google website:

http://developer.android.com/resources/tutorials/hello-world.html


when i completed the 'Run the Application' step, i got this error message on the console tab.

[2011-07-13 16:22:48 - Emulator] invalid command-line parameter: Files.
[2011-07-13 16:22:48 - Emulator] Hint: use [email protected]' to launch a virtual device named 'foo'.
[2011-07-13 16:22:48 - Emulator] please use -help for more information


the problem was that i have a 64bit windows 7 pc and the path for the SDK location was D:\Program Files (x86)\Android\android-sdk

so i needed to change the Program Files (x86) to D:\PROGRA~2\Android\android-sdk

13p-8455-eclipse-preferences.jpg

if you have another OS like windows 7 32bit, you can use this website as preferences,

if you have windows XP for example:
change from:
C:\Program Files\Wallpaperama\Android\android-sdk
to
C:\PROGRA~1\Wallpaperama\Android\android-sdk

if you have something else where you installed your android SDK:
change from:
C:\Andoid Apps\Wallpaperama\Android\android-sdk
to
C:\ANDROID~1\Wallpaperama\Android\android-sdk

so basically, the problem is the spaces. there should not be any spaces in your SDK location



after i was able to fix the SDK location, i didnt get the error anymore
13p-8455-android-hello-world.jpg

UPDATE: thank you for all your comments. i appreciate all the +1
i see that many of you are asking where do you make the changes... a picture is worth a thousand words, but a video is worth a million!!! so i made a short video how to make the changes