i was getting this error when i was trying to install android SDK on eclipse. i found out that i downloaded the wrong version. and older version i had downloaded the classis 3.1, instead i should have downloaded the latest which is 3.7 so after i did, i dint get this error anymore:

Android Development Tools (12.0.0.v201106281929-138431) requires plug-in org.eclipse.core.runtime (3.5.0), or later version.

as i ready the google tutorial is said:

if you will be developing in Eclipse with the Android Development Tools (ADT) Plugin—the recommended path if you are new to Android—make sure that you have a suitable version of Eclipse installed on your computer as described in the System Requirements document. If you need to install Eclipse, you can download it from this location:


The "Eclipse Classic" version is recommended. Otherwise, a Java or RCP version of Eclipse is recommended.

so i did go to http://www.eclipse.org/downloads/ but i didnnt see anything, it was overwhelming, so i google searched 'eclipse classic' and it took me to this url

http://www.eclipse.org/downloads/moreinfo/classic.php (Eclipse Classic 3.3.2)

so thats the one i installed, version 3.3.2

and thats when i got the error because the android SDK needs 3.5.0 o newer. so i went back to http://www.eclipse.org/downloads/ and found the latest version is 3.7 which is higher than 3.5 so it should work.

you can download the latest version here:

hope that helps anyone