This is the answer to fix XAMPP error message that says: Access Forbidden New XAMPP security concept:

I just completed installing XAMPP on my linux box on my USB drive. everything was working fine. except when I tried to access my database through http://localhost/xampp/phpmyadmin

Then I got this error message:
Access forbidden!

New XAMPP security concept:

Access to the requested object is only available from the local network.

This setting can be configured in the file 'httpd-xampp.conf'.

If you think this is a server error, please contact the webmaster.
Error 403
Apache/2.4.3 (Unix) OpenSSL/1.0.1c PHP/5.4.7

I read a bunch of posts on the xampp forums but none was able to fix them. They said something about my .htaccess and trying to edit the file called httpd-xampp.conf which by the way is not easy to find.

The location for httpd-xampp.conf is /opt/lampp/etc/extra/httpd-xampp.conf and edit this section:

# New XAMPP security concept
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
    Order deny,allow
    Deny from all
    Allow from ::1 \
        fc00::/7 \

    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var

Some posts said to change Deny from all to #Deny from all but still that didnt work for me.

What finally worked?? it was easy. I should have read the instructions. all I had to do is send this command on the linux shell:

# /opt/lampp/lampp security
then you will be asked to setup your passwords for each default:

xampp user: lampp
mysql user: pma
ftp user: nobody

After you have completed the passwords, reload http://localhost/phpmyadmin and you will be prompted to enter the password, so just enter the mysql password