while you are surfing the net, i sometimes use some site that just has too much ads. so i disbabled viewing images, but i was still getting ads in flash. so to disable flash, this is what i did in internet explorere:

go to tools > internet option

select SECURITY tab > Click on Custome Level button

now look for Run Activex controls and plug-ins and make sure to select Disable

then click OK, Then OK again to close internet option

thats it