i caught this error on my server error log one day when i was trying to upload a picture to my website, it kept giving me a 500 server error. i researched and finally took a look at my server error log and thats when i saw this error:

mod_fcgid: HTTP request length 136806 (so far) exceeds MaxRequestLen (131072)

my situation was that i was using ispconfig which uses fastcgi in my php. so all i had to do is put FcgidMaxRequestLen 3000000 in my directives.

so just go tot he ispconfig control panel under the site and in the options tab, you will populate Apache Directives with FcgidMaxRequestLen 3000000

thats it

NOTE: if you have ispconfig 3 on your linux server, you can find more information on this website: