Cp Command Problems Forcing Overwrite Using cp Command In Linux

Forums » Linux Systems » Cp Command Problems Forcing Overwrite Using cp Command In Linux
This Page Contains information about Cp Command Problems Forcing Overwrite Using cp Command In Linux By wallpaperama in category Linux Systems with 18 Replies. Last Upated: Thu May 15, 2014
today i was trying to copy a many files and when i send this command: Command:
cp -rf /this/file /to/this/file
i get this prompts: Command:
cp: overwrite '/this/file /to/this/file' ?
when i look at the man pages for cp it says:
-f, --force
              if an existing destination file cannot be opened, remove it  and
              try again
so it shouldn't ask me, so i found out that de defaults on the dedicated linux server we got from www.webune.com has cp as alias. so if you having this same problem, then run this command to see your alias: Command:
alias
OUTPUT:
alias cp='cp -i' alias l.='ls -d .* --color=tty' alias ll='ls -l --color=tty' alias ls='ls --color=tty' alias mv='mv -i' alias rm='rm -i' alias which='alias | /usr/bin/which --tty-only --read-alias --show-dot --show-tilde'
as you can see, i do have an alias with cp so how do you overwrite without prompt? what i need to do is remove that cp alias witht he unalias command so i send this coommand: Command:
unalias cp
so now when you do the alias command, you wont see the cp alias anymore so what happens if your not the admin or dont have access to root, then you can run an unaliased cp command, try Command:
$ /bin/cp -rf /this/file /to/this/file
hope this helps.. thanks for the guys at www.webune.com for their support on this question
copy
i recommend that isp's or unix systems with users who may be unfamiliar with unix setup the following aliases:

clr clear
cls clear
copy cp -i
del rm -i
delete rm -i
dir ls -alg
home cd ~
ls ls -f
md mkdir
move mv -i
pwd echo $cwd
type more
Osman
it did helped. thank you
Chad
i was wondering why the silly box kept insisting on permission to 'cp' everything! thank you ever so much for the great tip!
Dany
or you can use \ in front of cp -f <source> <destination> command which will temporarly disable the alias.
Fletch
Sia
nice one, thanks for that. pretty sure debian doesn't have tha alias by default. i'm kinda new to centos, and this was bothering me.
os3009
thanks.. very useful tip i tried every step and worked fine
Oleg
Thanks a lot! I've been wondering why would it ask me all the time to overwrite or not to overwrite the file. I had the same alias so thanks a lot again for the tip!
g33kinfo
you can also add a \ in front of the command to temporarily disable the alias... \cp -rf /this/file /to/this/file g33kin
maggo
- at - g33kinfo the command \cp -rf /this/file /to/this/file doesn't work on my machinse centos 5.4 any ideas?
Mamun
I want to dont show overwrite commend for cp. So what i do now. Overwrite?
John
I know this topic is old but you can also use 'cp'.
talha
it worked thank you for your sharing
Georg
Thanks it helped!
Ms
Great information, Thank you!!
Frank
You da man!!!!
meh
love the layout of your instructions. clear and concise!
Praxis
Yet another customer served, the '\cp -f' option worked a charm on Debian.
Title: Cp Command Problems Forcing Overwrite Using cp Command In Linux [2989]
Tags: cp command problems forcing overwrite using cp command
By
Comments 18
Visits 23401