(98)Address Already In Use: Make_sock: Could Not Bind To Address 80

Forums » Linux Hosting » (98)Address Already In Use: Make_sock: Could Not Bind To Address 80
This Page Contains information about (98)Address Already In Use: Make_sock: Could Not Bind To Address 80 By linuxuser with 40 Replies. Last Upated: Fri Apr 11, 2014
hi there, was wondering if you could help me with this error i am getting. i was trying to restart my apache server on my linux machine when i got this error i have never seen before, can anyone tell me what this error means?
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
but when i did it again, i was able to get my httpd apache server to restar, but i was just wondering what this mean? thanks
tartl
if for some reason you are still having problems, you can edit your httpd.conf file and look for where it says:

Listen :443

comment out this line and restart your web server and it should work. i would also try rebooting your machine if it continues. by rebooting, you will reload all your applications.
Ravikumar
# /etc/init.d/httpd restart
stopping httpd: [ failed ]
starting httpd: (98)address already in use: make_sock: could not bind to address [::]:80
(98)address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
unable to open logs
[failed]
Goitom
there could be several reasons for this to happen, however the case that happened to me was that i had setup an ip address that was provided by an isp (leased based) for apache to listen for requests and that ip was expired.
http://wallpaperama.com/forums/98address-already-in-use-make-sock-could-not-bind-to-address-80-t1091.html
gangadhar
# /etc/init.d/httpd restart
stopping httpd: [ failed ]
starting httpd: (98)address already in use: make_sock: could not bind to address [::]:80
(98)address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
unable to open logs
[failed] what will i do my http server is no runnig plz send reply
paddy
i had the same problem. commneting the listen 80 line httpd.conf line and then restarting the httpd service fixed my issue.

i am using port formwarding dynamicdns
EliasHickman
i also had the same problem. when i commented out listen 80 in my /etc/httpd/conf/httpd.conf file on my fedora 8 box, it worked like a charm.
aa_gen
hello :)
in /etc/httpd/ do :
find . | xargs grep "0.0.0.0:80"

you will find some files
( for me : this command return in exemple)
./conf.d/system-config- value from 0.0.0.0:80 to *:80

in every file found
aa_gen
hello :)
in /etc/httpd/ do :
find . | xargs grep "0.0.0.0:80"

you will find some files
( for me : this command return in exemple)
./conf.d/system-config- value from 0.0.0.0:80 to *:80

i have made the change for two files
/etc/httpd/httpd.conf
/etc/h
Ken
i also had the same problem. when i commented out listen 80 in my /etc/httpd/conf/httpd.conf file on my fedora 8 box, it worked like a charm.
flowersall
try turn orr virtual host 0.0.0.0:80
phpunit
i also get this on my windows 2003 server with microsoft sql

address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
sreejith
1)kill all nobody process. use the following script for doing that.

for i in `ps auwx | grep -i nobody | awk {'print $2'}`; do kill -9 $i; done

2) if apache is not restarting after this. remove semaphore using the following script.

for i in `ipcs -s | grep nobody | awk '{print $2}'`; do ipcrm -s $i; done

3) restart apche.
norman
this is my error:


starting web server: apache2(98)address already in use: make_sock: could not bind to address [::]:80 (98)address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down unable to open logs
schimmer
i took 3 hours to solve the issue. for reference: in conf file : servername localhost
listen 80

it is ok for me.
vithya
give the solution for this error: (os 10048) only one usage of each socket address (protoclo / network / adress /port) is normally permitted: make_sock: could not bind to address 0.0.0.0.80 no listening sockets available, sutting down unable to open logs in apache 2.0
sreejith
hi bose issue the following commands to sortout this issue:-
root at del [~]#for i in `ps auwx | grep -i nobody | awk {'print $2'}`; do kill -9 $i; done

root at del [~]#for i in `lsof -i :80 | grep http | awk {' print $2'}`; do kill -9 $i; done
2) if apache is not restarting after this. remove semaphore using the following script.

root at del [~]#for i in `ipcs -s | grep nobody | awk '{print $2}'`; do ipcrm -s $i; done

3) restart apche.
root at del [~]#/scripts/restartsrv_httpd
Shane
i could see the correct fix in the following url:-
openhelp.info/index.php?option=com_
Ron
ken's suggestion worked for me. i was getting (98) address already in use: make_sock: could not bind to address [::] when ever i ran:
# apachectl start
or
# service httpd start
if i ran:
# apache status
i would get: httpd dead but subsys locked

anyhow i went into htttpd.conf and commented out "listen *:80"
this worked, but i still don't what happened and why this solution worked.
shanestar007
i found the solution here:-
openhelp.info/index.php?option=com_
shameer
please just run the command

fuser -k -n tcp 80
ZeroCool
please stop iis server from windows service
(administrator tool -> services - > world wide web)

and start apache
cjl
hey,guys!watch me,i also had the same issue and i just changed the port,such as 88. restart apache and it works.even i didnt know what had happened!
Shuvo
try this:

$ sudo fuser -k -n tcp 80
$ sudo /etc/init.d/httpd -k start
Pardeep
Thanks. Your solution is working fine.
rachman
it seems like another web server daemon already running,,, if u use xampp, try to stop it first, /opt/lampp/lampp stop, then try to starting httpd #service httpd start
mathan
hi when i tried to ssl in apachectl config and finished all steps in ssl but is following error coming when i start the apachectl start or restart. # /etc/init.d/httpd restart Stopping httpd: [ OK ] Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80 (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs
rob
Changing the port number in your httpd.conf file works a charm.
msi
if u have a nic configured with the ip that httpd will listen to it should work fine , if u r using floating ip , virtual ip that will be created as a cluster resource change the ip address i.e if u have have two nics, nic1 192.168... and nic2 10.0... it will work for 10.0.. and will not for 192.168 .. why I dont know ;) if u know tell me
abcded
Restarting web server: apache2(98)Address already in use: make_sock: could not bind to address [::]:8080 what to do guys i am getting that error while starting apache...
Sod
$ sudo fuser -k -n tcp 80 $ sudo /etc/init.d/httpd -k start It helped me in my Debian server. Thanks Shuvo.. :)
amol
following error coming when i start the apache start or restart. /etc/init.d/httpd restart Stopping httpd: [FAILED] Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName (98)Address already in use: make_sock: could not bind to address [::]:80 (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs [FAILED]
willians
thanks Shuvo. my apache it works now.
Buti
Hello just had the same error message on Fedora 13 and this is how it was solved. Change the listen port in the httpd config file to 81, by doing this we want to see which service is using port 80. as root do the following: #netstat -tlp after running the command. Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1546/sshd tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 1429/cupsd tcp 0 0 127.0.0.1:5432 0.0.0.0:* LISTEN 1592/postmaster tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2360/sendmail: acce tcp 0 0 0.0.0.0:8554 0.0.0.0:* LISTEN 3207/gnome-dvb-daem tcp 0 0 0.0.0.0:54858 0.0.0.0:* LISTEN 1369/rpc.statd tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1310/rpcbind tcp 0 0 :::59092 :::* LISTEN 1369/rpc.statd tcp 0 0 :::22 :::* LISTEN 1546/sshd tcp 0 0 ::1:631 :::* LISTEN 1429/cupsd tcp 0 0 :::443 :::* LISTEN 2593/httpd tcp 0 0 :::6881 :::* LISTEN 2757/ktorrent tcp 0 0 :::111 :::* LISTEN 1310/rpcbind tcp 0 0 :::80 :::* LISTEN 2593/httpd tcp 0 0 :::81 :::* LISTEN 2593/httpd now we know that port 80 is utilised by another service, so locate and change system-config-httpd.conf: system-config-httpd.conf system-config-httpd.conf. all of this, restart httpd: /etc/init.d/httpd start that was not hard...was it now.
wtsang
Commenting out Listen 80 will work because there is another Listen statement listening to the same port i.e. Listen [server ip addr or name]:80.
pmg
$ sudo fuser -k -n tcp 80 $ sudo /etc/init.d/apache2 start
harry
Hey , This ,means some process ir running which is using this port so try to kill that process like get the process eg : ps -ef | grep httpd then kill the process eg kill -9 process ID this worked for me
Lucas
pmg thanks!
kampreto
thanks, it's work for me
Yan
$ sudo fuser -k -n tcp 80 this worked on centos. Thanks a lot!!! Apache was down for an hour and ISPs control panel occupated port 80
Sydney
Thanks man really helped out a lot
StandDuPp
Worked for me in Debian Lenny.
Many thanks.
Title: (98)Address Already In Use: Make_sock: Could Not Bind To Address 80 [422]
Tags: 98address already in use make sock could not bind to address 80